Subtasks Set to Null due to 'Field Issuetype No Issue Type Selected'

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Search results in the Issue Navigator are erroring and not displaying any results. Errors like the following appear in your logs:

1 2 3 4 2009-06-10 08:10:32,258 http-443-Processor44 WARN [workflow.function.issue.TransitionSubtasksFunction] Field validation error auto-transitioning subtask CXM-957: 2009-06-10 08:10:32,258 http-443-Processor44 WARN [workflow.function.issue.TransitionSubtasksFunction] Field issuetype: No issue type selected. 2009-06-10 08:10:32,383 http-443-Processor44 WARN [workflow.function.issue.TransitionSubtasksFunction] Field validation error auto-transitioning subtask CXM-974: 2009-06-10 08:10:32,383 http-443-Processor44 WARN [workflow.function.issue.TransitionSubtasksFunction] Field issuetype: No issue type selected.

Cause

The Subtask Auto-transition plugin (Now Deprecated) is setting the Issue Type column in the jiraissue table to null.

Resolution

  1. Check if the transition screen that is being auto-transitioned contains issue type. If so, remove it.

  2. To find the issues that have already been set to null, run the following query in the database:

    1 2 3 4 5 6 7 8 9 10 11 12 SELECT jiraissue.pkey, jiraissue.issuetype FROM jiraissue LEFT OUTER JOIN issuetype ON ( jiraissue.issuetype = issuetype.id ) where issuetype.pname is null
Updated on April 8, 2025

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