Sub-task issue type got changed from Sub-task to standard

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

A subtask issue type is moved from subtask to standard issue type.

Environment

  • 8.x onwards

Diagnosis

  • Check the database to confirm issue type details. Here is the result for

    1 select * from issuetype;
    Example result of pname column.
  • In this example the pstyle value for Sub-task is expected to be jira_subtask. However, it is set to null.

Cause

unknown

Solution

Below mentioned steps will help to recover from the situation:

  1. Capture the issueId by executing the query mentioned below:

    1 select id from issuetype where pname='sub-task';
  2. Execute below mentioned query to move the standard issue type to subtask issue type:

    1 update issuetype set pstyle='jira_subtask' where id='XXXXX'; 

    Note

    • Replace XXXX by ID captured in step 2

    • Update query is tested with PostgresSQL database

    • Make sure to take database backup before making any updates

  3. Commit the changes.

  4. Restart the instance for the changes to take affect.

Updated on March 13, 2025

Still need help?

The Atlassian Community is here for you.