Sprint cannot be completed as there are incomplete subtasks in Jira Cloud

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

When trying to complete a sprint, an error message warning of incomplete sub-tasks appears, even though all sub-tasks in the sprint were completed.

Solution

Common causes

Sub-tasks are in a status that is not mapped to the rightmost column of your board

Issues are only considered "completed" when their status is mapped to the very rightmost column of your board.

  1. Open the issue key(s) mentioned in the error message

  2. Open any linked subtask(s) and take note of the status

  3. Open Configure Board → Columns

  4. Check for any of the sub-task statuses from step 2 in columns other than the rightmost column

  5. Remap those statuses to the rightmost column to allow sprint completion

Take special care to check the Unmapped statuses section. Issues in these statuses will also not be considered complete.

Sub-tasks are being filtered out of the board, but are included in the sprint

Confirm your board filter is not filtering out sub-tasks. This can often happen if your board filter JQL specifies a list of issue types.

When sub-tasks are excluded from a board, they often get forgotten and may not have been completed or set to a properly mapped status.

Updated on April 2, 2025

Still need help?

The Atlassian Community is here for you.