Specific project type not available in Jira

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When trying to create a new project in Jira, you may notice that Software, Service, or both project types may not be available to be selected. In the example below we can see only the Business and Software types.

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Similarly, when accessing the Projects menu, you may see that the respective project type is marked with an empty and dotted icon.

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Cause

The reason for this is the specific Jira app (Jira Software or Jira Service Management) is either not installed or is currently disabled.

ℹ️ If the application is installed and enabled but not licensed, you won't be able to create the respective project type on your instance, but it will not be listed with the empty and dotted icon.

Solution

Checking if the application is installed

To validate whether Jira Service Management and Jira Software are installed, you may simply navigate to Jira administration (gear icon) > Applications > Versions and licenses.

On this page, you should be able to verify which of the two app modules are installed (if any).

In the example below, we again have an example where Jira Software is installed while Jira Service Management is not.

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Installing the apps

In case you can confirm that, indeed, the app is not installed, either through the above message or by the absence of the app version on the page, you can proceed to install it without a service interruption by simply hitting Install on the warning message.

If the message is not present you may instead utilize the Try for free button on the "Other Jira applications" section in the bottom right.

If the applications are already installed

If you can confirm that the application was already installed or you continue to notice the same issues after installing it, some of the required modules for the app may have been disabled during the Jira initialization.

To re-enable them we can follow the instructions below:

  1. Shut down all Jira nodes.

  2. Log into the Jira database, and run the following query:

    Please note that the example worked fine using MySQL. In PostgreSQL, for example, the schemaName before the table name is required.

    1 DELETE FROM pluginstate;

    ℹ️ The pluginstate table only stores information about disabled plugins, so deleting its contents will basically tell Jira to activate all its plugin modules. There will be no data loss by performing this deletion.

  3. Commit the changes if necessary.

  4. Start Jira again.

Updated on April 24, 2025

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