Specific Issue links are not reflected in Front end but available in Back end after the Project migration
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
After migrating a project between Jira instances, some users have experienced an issue where "Child Issues" are not properly displayed on the front end despite being available in the database. This article outlines how to diagnose and resolve this issue.
Environment
9.4.6
Affected Plugins: Project Configurator for Jira, Advanced Roadmaps Plan.
Diagnosis
Check if the issuelink table contains all the necessary data.
Verify if there are missing values in the entity_property table, specifically for the column PROPERTY_KEY=jpo-issue-properties.
Cause
Compatibility issues with third-party plugins like Project Configurator for Jira and Advanced Roadmaps Plan.
A mismatch or missing entries in the database, especially within the entity_property table.
Limitations with the native Jira issue exporter, as noted in feature request ticket JPOSERVER-1477.
Solution
Database Checks: Run SQL queries to compare the issuelink and entity_property tables in both source and destination databases.
Manual Update: Consider manually updating missing or mismatched records in the entity_property table.
Note
Please ensure that to have a backup of JIRA database handy before performing any direct database manipulation. Atlassian will not be held responsible for any lost of data due to the absence of backups.
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