Sort "Fix Version/s" into a correct order on the Issue Search result

Platform Notice: Cloud and Data Center - This article applies equally to both cloud and data center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

The Fix/Affected Versions is not sorted accordingly (by its name) on a search result when querying JQL with ASC or DESC sort order. See the following screenshots:

For ASC sort order:

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For DESC sort order:

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Cause

In the Project > Project Settings > Versions page, the version is not sorted as well:

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Resolution

Rearrange the versions accordingly by drag and drop it into the correct order:

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Fix/Affected Version should be sorted accordingly.

For ASC sort order:

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For DESC sort order:

(Auto-migrated image: description temporarily unavailable)
Updated on April 11, 2025

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