Error Viewing Objects in Jira Service Management Cloud Object Type

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

Encountering an error when accessing objects of a specific type in Jira Service Management Cloud.

Something's gone wrong

Our team has been notified. If the problem persists, please contact Atlassian Support.

ERROR: XXXXX

Diagnosis

Inspect the Browser console logs at the time of the error, the following error is returned:

Error: Label should always be a default text attribute

Run an AQL to search if any of the objects have an empty value in the label attribute:

Label is empty

If any object is returned, then move ahead with the next steps to fix it.

Cause

The error happens when an object has no value in its "Label" attribute. Every object must have a value for its Label attribute. This issue often arises if you modify the Label attribute.

Solution

To fix this:

  • First, set another attribute as the "Label" attribute by going to your attribute configuration and going to three dots (•••) > Set as label.

  • Ensure that this attribute is not empty for any of the objects (prefer the attribute that was previously the "Label" attribute; by default, it is the attribute "Name"). This will load all the objects.

  • Next, add values in all the objects for the attribute that you would like to set as "Label". Once this is done, set this attribute back as the Label attribute.

Updated on May 12, 2025

Still need help?

The Atlassian Community is here for you.