Some Completed Sprints are not visible in the "Release Burndown" report

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Problem

There are a number of completed Sprints that are within the date range of the Release start and end date but they are not showing up on the Release Burndown report.

Some other Sprints, however are showing up fine.

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(Auto-migrated image: description temporarily unavailable)

Diagnosis

Looking closer, the issues from the missing Sprints are showing up under the Before initial sprint section of the report.

We have an open suggestion requesting for the baseline date used to determine the initial sprint to be displayed in the report. This may help understand and track what actions drive the report.

JSWSERVER-21302 - Display information about baseline date of the initial sprint on Release Burndown Chart

Cause

ℹ️ This is not a bug, but at the same time, JIRA will not be able to handle this behaviour the way it might be expected to.

Basically, when a release is established, the first issue created in the first sprint associated with the version will establish the baseline of the initial sprint. This cannot be changed or modified. The moment an issue from a Sprint is added to a version, that moment decides the starting point for the report. All the issues from earlier Sprints that get added to the version, will be added to the Before initial sprint section.

The reason this behaviour occurs is that first and foremost, Agile is a planning tool. Making changes retroactively to a version like this after the issue and sprint are already Done will skew your reporting and the application is not built in a way which would accommodate otherwise. This is why the issue is being considered as part of the Original estimate, as the work done on the issue was not done during the Version itself.

Solution

Workaround

In some cases, the problem can get fixed by reopening and then closing each of the issues in the missing sprint. Then, those get displayed again and the report is correct.

Resolution

It is unfortunately not possible to change the report now, as it represents a snapshot of a point in time. However, the only way to prevent this from happening is to not add already closed issues to a version at a later point in time.

Updated on April 11, 2025

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