Service Management is stuck at loading after upgrade to version 3.3

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Problem

After upgrading to Jira Service Management 3.3.x, when user tries to open a page in service project (Customer list, Project settings, Queues, etc.), the page is stuck at loading (see screenshot below)

(Auto-migrated image: description temporarily unavailable)

And the following error of Failed to load resource: net::ERR_TOO_MANY_REDIRECTS is thrown in browser console

(Auto-migrated image: description temporarily unavailable)
(Auto-migrated image: description temporarily unavailable)

Diagnosis

  • The web requests being made here are actually including an unexpected path to jira-url/projects/ProjectKey/null/s/..... as seen in this browser console.

  • The dark feature jira.fixed.cdn.enabled is enabled in Jira.

  • However the Jira system property jira.fixed.cdn.prefixis not set.

Cause

The dark feature jira.fixed.cdn.enabled enables JiraPrefixCDNStrategy. To make it work properly Jira system property jira.fixed.cdn.prefix should be set to CDN prefix, but it's not set which results in bad URL with 'null' inside.

Solution

Resolution

Please follow the steps below to disable the dark feature

  1. Navigate to jira-url/secure/SiteDarkFeatures!default.jspa

  2. Locate jira.fixed.cdn.enabled and press Disable (this will remove it from the list of dark features).

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.