Search or View Issues Cause System Error
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
Trying to search or view issues results in a System Error. The following appears in the atlassian-jira.log
:
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java.lang.NullPointerException
at com.atlassian.jira.security.type.GroupCF.getQueryForGroupName(GroupCF.java:105)
at com.atlassian.jira.security.type.GroupCF.getQueryForGroups(GroupCF.java:97)
at com.atlassian.jira.security.type.GroupCF.getQueryForSecurityLevel(GroupCF.java:124)
at com.atlassian.jira.security.type.AbstractIssueFieldSecurityType.getQuery(AbstractIssueFieldSecurityType.java:73)
at com.atlassian.jira.security.type.GroupCF.getQuery(GroupCF.java:68)
at com.atlassian.jira.security.type.AbstractIssueFieldSecurityType.getQuery(AbstractIssueFieldSecurityType.java:95)
Cause
There is an error with the issue security scheme permissions returning null value.
Resolution
Go to
Administration > Issues > Issue Security Schemes
Check the
Security Levels
and remove any users/groups that do not actually exist in the system. Also, remove any User Custom Fields, or Group Custom Fields that do not actually exist in the system.
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