Search inconsistent with custom field type in the List, Timeline and Calendar view.

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

When a user types a few keywords on the search box for the custom field type (Text Field (single line))in the list view, then it doesn't display issues and sometimes it displays multiple issues for Jira project as shown below in the screenshots.

(Auto-migrated image: description temporarily unavailable)
(Auto-migrated image: description temporarily unavailable)

But if we type the full keyword in the search box, it displays the issue in the list view:

(Auto-migrated image: description temporarily unavailable)

Environment

Jira Cloud

Cause

This is the expected behaviour as the search in the list, timeline and calendar view is done via JQL.

Solution

If we pass in 993 in the search box, the JQL we send becomes:

text ~ 993*

The

*

at the end means we apply fuzzy search, but only in that direction (after the search term typed, not before it). Therefore it is an expected behaviour in the list, timeline and calendar view search.

Updated on April 8, 2025

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