SAML logins fail with class initialization error in Jira Server
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
After configuring SAML in Jira and attempting to login, the login fails and the following error is observed in the atlassian-jira.log:
1
2
3
2020-05-15 15:52:01,312 http-nio-8080-exec-44 url:/plugins/servlet/samlconsumer username:xxx ERROR xxx 952x12261098x4 /plugins/servlet/samlconsumer \[c.a.p.a.i.web.filter.ErrorHandlingFilter] Received invalid SAML response: Could not initialize class com.sun.org.apache.xerces.internal.impl.dv.xs.SchemaDVFactoryImpl
com.atlassian.plugins.authentication.impl.web.saml.provider.InvalidSamlResponse: Received invalid SAML response: Could not initialize class com.sun.org.apache.xerces.internal.impl.dv.xs.SchemaDVFactoryImpl
at com.atlassian.plugins.authentication.impl.web.saml.provider.impl.OneloginJavaSamlProvider.lambda$extractSamlResponse$1(OneloginJavaSamlProvider.java:89\
Diagnosis
Generate a support zip and review the
application.xml
file located in theapplication-properties
folder.Search for the <sun.boot.library.path> or <java.version>.
Compare the results to the java version returned by running the command:
java -version
on the server where Jira is hosted.
If the versions are different, you will need to restart Jira to correct.
Cause
The Java version on the server where Jira is hosted was updated while Jira was running. In order for Jira to use the new version of Java, Jira must be restarted.
Solution
Restart Jira.
Was this helpful?