Running Jira bat tasks and executables on Windows throws the error: Access Denied - This app can't run on your PC
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
On a Windows host, when we try to run commands with the "tomcat9w" executable to apply changes in the JVM settings,we receive the following error:

Also, when running the service.bat installer and a few other bat jobs from the cmd prompt, the same error causes the message "Access denied.":

Cause
The cause of this problem is that at least one of the Tomcat executables became broken/empty/invalid.
To validate the root cause, follow these steps:
Go to the <JIRA-INSTALL>/bin directory
Check the file size of all the "tomcat9" executable files:
If any executable is empty, 0 Mb, we'll need to replace it.
How the file corruption happens?
Unfortunately, we don't know why the executables get corrupted and we don't know how to replicate it for further investigation.
Solution
We need to download a healthy fresh copy of the Jira application, gather the same files and overwrite the broken ones:
Download the ZIP package of the same version of your installed Jira from the Jira Data Center download archives
Unzip the package, navigate to the bin directory and copy the appropriate new exe files
Navigate back to your <JIRA-INSTALL>/bin directory and paste/overwrite your broken files with the new ones.
That's it, your application, bat, etc should work now!
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