REST API search endpoints are slower compared to issue navigator
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
When running a JQL search using REST API, the results are returned significantly slower than the issue navigator.
Environment
Jira 7.13 and later , 8.x, 9.x, 10.x
Cause
By default, if no fields are specified when searching via REST, all fields are returned. The results are quicker from the issue navigator GUI is because not all fields are selected.
We have a suggestion ticket to improve this here:
Please also take note of this known bug :
Workaround
When performing REST api searches, ensure to specify the fields for example :
1
{base_url}/rest/api/2/search?jql=text%20~%20task\&fields=summary,description,reporter,assignee
If you have recently updated a plugin and just started facing this issue, tracking down which plugin custom field is causing this issue will also help. You may try disabling a few of those plugins that you recently updated and run the REST API command again to see if there are any differences in the time. If it is indeed faster, you can then enable the plugin one by one until you find the plugin which has the field that is causing the slowness.
Was this helpful?