Respond to Customer and Internal Comment tabs missing from comment in Jira Service Management

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

In issues created in Jira Service Management (JSM) projects, the comment field does not show the option to either add it internally or share it with the customer:

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Normally, in JSM issues, we should have the option to either add a comment internally or share it with the customer, as shown below:

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Environment

Jira Service Management (JSM) Server/Data Center on 4.0.0 or any higher version.

Cause

This is usually caused by having the service-desk-comment-field module of the Jira Service Management app being disabled:

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Diagnosis

To verify if this root cause is valid, follow the steps below:

  • Log into the Jira application as a Jira System Administrator

  • Go to ⚙ > Manage Apps > Manage Apps

  • Search for Jira Service Management and filter by All apps

  • Click on the Jira Service Management app to expand it

  • Click on XXX of XXX modules enabled to view the full list of modules

    (Auto-migrated image: description temporarily unavailable)
  • Scroll down to the service-desk-comment-field module and verify if it is disabled, as shown in the screenshot below:

    (Auto-migrated image: description temporarily unavailable)

Resolution

  1. Log into the Jira application as a Jira System Administrator

  2. Go to ⚙ > Manage Apps > Manage Apps

  3. Search for Jira Service Management and filter by All apps

  4. Click on the Jira Service Management app to expand it

  5. Click on XXX of XXX modules enabled to view the full list of modules

  6. Locate the service-desk-comment-field item in the expanded list

  7. Click the Enable button to enable it

Known issue

This workaround no longer works well on Jira Service Management versions above 5.4.5. The Add Comment button redirects Jira users to a new page, instead of keeping them in the "View Issue" screen.

This bug is tracked in https://jira.atlassian.com/browse/JSDSERVER-14915.

Updated on April 2, 2025

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