Resolve Uninstalled App Reappearing in Jira DC Manage Apps Post-Restart
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
After uninstalling an app and restarting Jira Data Center, the app still appears on the Manage Apps page.
Diagnosis
After an app is uninstalled from the UI, restart Jira Data Center. Use the following steps to verify if the uninstall was successful:
Navigate to Administration ⚙ > Manage Apps.
Select Manage Apps from the sidebar.
The app can be found on the list here. However, it may be greyed out and show as Incompatible.
Cause
There are two main causes for this behaviour:
The plugin cache is corrupted and causes uninstalled apps to reappear.
There may be leftover files in the
installed-plugins
directory where Jira stores its apps.
Solution
Locate your JIRA_HOME
directory
If you are unsure of the location of your JIRA_HOME
directory, use the steps described in Find the location of the Jira home directory.
Clear the Plugin cache
Clear the plugin cache. Please use the steps mentioned in the article: How to clear Jira Data Center plugin cache.
Clear the installed-plugins
directory
Please ensure there are no leftover files in the installed-plugins
directory, where Jira stores its apps, using the following steps:
Go to the
JIRA_HOME/plugins/installed-plugins
directory.Check for any JAR files related to the app and manually remove them if found.
Clear the plugin cache.
Restart the application.
Verify that the issue is fixed.
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