Resolve the error “You must specify a summary of the issue” to create issues in Jira

Platform Notice: Cloud Only - This article only applies to Atlassian apps on the cloud platform.

Summary

When attempting to create an issue, the error message “Summary: You must specify a summary of the issue.” appears, preventing issue creation.

Diagnosis

  1. Attempt to create an issue in a project.

  2. Notice that the “Summary” field is missing from the issue creation screen.

  3. Receive the error: “Summary: You must specify a summary of the issue.”

Cause

The Summary field is missing from the work item screen.

Solution

Add the Summary field to the work item screen.

  1. Go to Space settings > Work Items > Screens for the relevant project.

  2. For the work type you want to update, select the edit button (pen icon) on the right.

    • If all work types use the same screen scheme, you’ll see the screen names immediately and can skip this step.

  3. Select the screen name for Create issue.

  4. At the bottom of the page, use the Select Fields … dropdown to search for Summary.

  5. Add the Summary field to the screen.

Updated on November 25, 2025

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