Resolve "group does not exist" error in Jira Data Center
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Jira is integrated with LDAP or Crowd. Upon adding a user to the group, Jira is able to auto-complete the group name in Jira, but upon clicking 'Update', the following error appears:

There is no correlating error in the atlassian-jira.log.
Diagnosis
There is no problem with the synchronization between the user directories.
The group is present in Jira, and the user can browse to the group in Jira.
Cause
There is a space in the group name in the Jira database. You can check this by executing the following query in the database :
SELECT group_name FROM cwd_group WHERE group_name LIKE '<Your Group Name here>%';
Solution
Always back up your data before making any database modifications. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.
Execute the following query to update the group name in the database:
UPDATE cwd_group SET group_name = trim(both ' ' from group_name); UPDATE cwd_group SET lower_group_name = trim(both ' ' from lower_group_name);
ℹ️ The above queries are designed for the Postgres database. You might need to change them to suit your database.
After this, restart Jira.
ℹ️ Please see our Troubleshooting LDAP User Management documentation for further assistance with diagnosing LDAP problems.
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