Resolve error "Invalid form link" when opening a ProForma form link

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When opening the direct link of a ProForma Issue Form (obtained from the Issue Form > Direct Link > Copy button), the error below is displayed:

"Invalid form link

This link is not connected to a form. Perhaps the issue or request types associated with this form have changed. Please contact your Jira or Project administrator for the correct link."

invalid form link error message

Diagnosis

  • Open the Form configuration page from the Jira Service Management project it was created from (via Project Settings > Forms > Edit)

  • Open the Settings tab of the Form configuration and check if the Issue Form panel is disabled. If it is, this KB article is relevant.

form settings with Issue Form selection turned off

Cause

The reason why the Form Direct link does not work is that the Issue Form is disabled.

When an Issue Form is enabled in the Form configuration, a button appears that allows users to get the direct link to the Form:

Issue form that is enabled and displaying Direct Link copy function

If the Form configuration is not saved via the Save button located in the top right corner after enabling the "Issue Form", the Issue Form will not be considered as "enabled" yet, and the following will happen:

  • The Direct Link will not work and throw the "Invalid form link" error in the UI.

  • Next time the Form configuration page is opened, the "Issue Form" will show as disabled.

Solution

Ensure you save the Form configuration after the Issue Form is enabled by selecting Save in the top right corner.

form settings with Issue From enabled and the save button highlighted

Updated on June 3, 2025

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