Resolve Epic Name Requirement on Create Issue Screen in Jira
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
When creating an issue in Jira Software, there is an Epic Name field which has been marked as Required on the Create Issue screen, even though the currently selected issue type is not Epic.

Cause
In the custom field configuration page, looking at the Epic Name custom field, we can see that its global context has been set to other issue types as well, as in this screenshot:

Resolution
You must first unlock the field to make it available for editing. Please follow this documentation to do so: Unlock a locked Jira Software Server or Data Center custom field
Once the unlock is complete, go to the Custom Fields administration page and look for the Epic Name custom field. Click on the cogwheel icon on the far right side to bring out the dropdown menu, and select CONFIGURE. Once here, you should see a Default Configuration Scheme for Epic Name. Click on the Edit Configurationbutton.
In the "Choose applicable issue types" section, there is a multi-select box with issue types inside it. Ensure that only the EPIC issue type is selected, and no other. Save the changes.
Relock your epic field, again using this documentation just performing the update command and
set
managed=
'true'
instead for the field that was altered before.
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