Resolve 'Actor Permission' Automation Error in Jira Data Center
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Jira Automation rule fails with the following error in the audit log:
The actor may not have permission to view one or more issues or they may have been deleted.
<id>
The audit log provides limited information about the error associated with ID <id>. As a result, identifying the exact issue and the project affected by this automation failure poses a challenge. Additionally, it is difficult to determine which project the relevant rule actor does not have the required permissions for.
Diagnosis
Retrieve the issue details for the Issue ID
To retrieve the Issue Key and project name associated with the specified Issue ID, please execute the following database query:
SELECT (p.pkey||'-'||i.issuenum) AS issuekey,p.pname AS Project_Name,u.user_name, u.display_name, w.issueid,w.author,w.created,w.updateauthor,w.updated,w.startdate,w.timeworked
FROM cwd_user u
JOIN app_user a ON a.lower_user_name = u.lower_user_name
JOIN worklog w ON a.user_key = w.author
JOIN jiraissue i ON i.id=w.issueid
JOIN project p on i.project=p.id
where w.issueid=<id>;
Replace the <id> in the query with the <id> from the error message.
This information will assist you (the Jira Administrator) in verifying the permissions of the rule's actor for the affected project.
Example Result
issuekey | project_name | user_name | display_name | issueid | author | created | updateauthor | updated | startdate | timeworked
----------+---------------+-----------+--------------+---------+---------------+-------------------------------+---------------+-------------------------------+---------------------------+------------
CT-1 | Check Test123 | Test1 | Test1 | 10402 | JIRAUSER10000 | 2025-06-15 16:12:26.509+05:30 | JIRAUSER10000 | 2025-06-15 16:12:26.509+05:30 | 2025-06-15 16:12:00+05:30 | 600
(1 row)
Cause
The error message is usually caused by permission issues or if the issue in question has been deleted.
Solution
Use one of the following two options to prevent this from occurring.
Change to a different actor
Navigate to the automation list.
For project automations, go to Project settings > Automation.
For global automations, go to Administration (⚙) > System > Automation rules.
Select the rule for which you want to edit the configuration.
Select the rule details.
Under Actor, search for a user with the correct permissions.
Change the permissions for the rule actor
Provide the necessary project permissions for the user.
Ensure the user is a member of the appropriate issue security scheme.
Was this helpful?