Request form with Forms on open portal not loading in JSM Cloud
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
When attempting to access a Request form linked to Forms containing a required Assets object within an Open Portal in a Jira Service Management Cloud project, an error message is displayed, and the form remains inaccessible.
Error message
We couldn't load this request
Log in with a valid account to access, or select a different request.

Environment
Jira Service Management - Cloud
Diagnosis
Assets Objects field type required in the JSM Forms associated with the request type.
Cause
Assests fields are not available for anonymous users in the Portal. This is a feature request suggested in our public tracker.
JSDCLOUD-10006 - As an Admin I want to allow anonymous user to be able to view and select options in an Assets Objects field in the Help Center (Portal)
JSDCLOUD-13422 - Ability to use Assets custom field for non login or login free customer portal
Solution
Ensure the field is not required;
Or you can follow the workaround below:
Create a select list custom field and add all the objects as the data.
Then, create automation to update the Assets object custom field according to the custom field value.
Was this helpful?