Replying JIRA Notification From Mobile Device Create New Issue
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Symptoms
A new issue will be created when replying JIRA notifications from mobile devices. However, replying to the same email from the desktop will add comment correctly to the issue.
Diagnosis
Trigger notification from JIRA instance
Generate raw email in the .eml format from the reply sent from both desktop and mobile devices.
Compare the header and check if the "In-Reply-To" and "References" exist in the .eml file
Cause
This behaviour is caused by third-party application. The email replied from the mobile devices does not have the header "In-Reply-To" and "References" and thus JIRA not processing the email as comment. There is also a bug in the stock Android Email App tracked at ID28017 that causes this behaviour.
Solution
Workaround
To ensure that replied added successfully as a comment, include the issue key in the email's subject.
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