Receiving error "Please provide a valid value for field 'Approvers'" when trying to set a user as approver

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

Please provide a valid value for field 'Approvers' error is thrown when trying to set a user as an approver

(Auto-migrated image: description temporarily unavailable)

Environment

Jira Service Management Cloud

Cause

This happens when a user has Product admin access but doesn't have any other Jira application access.

(Auto-migrated image: description temporarily unavailable)

When the user has only Jira Administration, then the user can't access Customer Portal or Jira Product and thus can't Approve any requests. So the system will not allow us to select this user in the Approver field.

Related bug:

Solution

There are two ways by which you can allow this user to be selected as Approver.

  1. Remove the user from Jira Administration Product Group. The user can access Customer Portal to Approve the requests.

  2. Add Jira Product License to the user, so that user can access either Jira or Customer Portal to Approve the requests.

In case the issue is still not resolved, feel free to contact Atlassian support.

Updated on April 11, 2025

Still need help?

The Atlassian Community is here for you.