Receiving an error message stating 'Unknown Error' when attempting to publish an Automation Rule
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When attempting to publish an Automation Rule within Jira the rule will not be published and an error message is shown in the Jira user interface stating 'Unknown Error'.
Environment
All versions of Jira Data Center running Automation for Jira.
Diagnosis
When capturing a HAR file, there is a 403 response provided to the endpoint <Jira Base URL>/rest/cb-automation/latest/project/GLOBAL/rule/<rule ID> while attempting to publish the rule.
Cause
This can occur if there is a Web Access Firewall (WAF) or proxy that is interfering with this PUT request. Jira is attempting to issue a PUT to this endpoint to publish the rule, however it has been observed that WAFs (such as CloudFlare) or proxies can issue authentication challenge verifications on this request depending on their configurations even if Jira is sending the proper cookies with the request.
Solution
To resolve this issue the rules for the WAF and or proxy would need to be modified to ensure that this request is able to make it to the Jira endpoint without needing additional authentication verification.
⚠️ While the configuration of the WAF/proxy is outside the scope of Atlassian Support, it would be recommended to work with the network administrators to review the WAF and or proxy to ensure that these requests can be successfully sent and received.
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