Reboot causes all ranking in Jira boards to be lost

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Issue ranking is lost after re-index or reboot. The following appears in the atlassian-jira.log:

1 2 2012-10-10 10:46:10,579 http-8090-4 ERROR Admin 646x162x1 n8oeo9 127.0.0.1 /secure/Rank.jspa [greenhopper.service.rank.RankServiceImpl] Invalid customFieldId 11121 passed to RankService.compareIssuePosition 2012-10-10 10:46:10,709 http-8090-4 ERROR Admin 646x162x1 n8oeo9 127.0.0.1 /secure/Rank.jspa [greenhopper.service.rank.RankCustomFieldServiceImpl] The GreenHopper rank custom field with id customfield_11121 and name Priority Rank is not global. This field must be global, thus associated with all issue types and use the global context, in order to correctly work.

Cause

Custom field mentioned on the error message needs to be set as global and associated with all issue types.

Resolution

  1. Execute the query bellow to identify which is custom field name related to the custom field id mentioned on the error message (e.g. customfield_11121)

    1  select cfname from customfield where id = <customfield>;
  2. Navigate to Custom Fields screen (Administration > Fields > Custom Fields) and to edit it click on "Configure" button, then click on "Edit Configuration

  3. On the "Choose applicable issue types" section, select "Any issue types"

  4. On the "Choose applicable context" section select "Global context"

  5. Save the modification

Updated on April 8, 2025

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