Quick Searching for Issues Fails
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
We are ending support for project key format configuration in JIRA 6.0. Please see this announcement for details.
Symptoms
Quick Searching for specific issues will not work when entering a valid issue key.
Instead of opening a specific issue, the search will be performed in the Issue Navigator and no results will be returned.
The Quick Search partially breaks, whereby it will fail to recognize the issue key. However, no errors will be appearing in the
atlassian-jira.log
.
Cause
There are a few reasons why the quick search resolve may be not resolving correctly.
There is white space at the end of the project pattern
The project pattern regex is not updated to reflect all project key patterns in your system
Resolution
Use the Configuring Project Keys page to configure your project key to reflect all patterns in your system. Remember to make sure there is no white space after then project key pattern regex.
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