Project Automation rule is not running when an issue is created

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Project Automation rule is not running when an issue is created, however, it is running properly for other events.

Diagnosis

✔️ For the same Project area, other rules are running fine;

The rule is not triggered independently of the new action executed (add comment, create sub-task, send notification);

✔️ The rule runs if the trigger is changed, for instance, to "field value changed";

✔️ The rule is triggered for other Project Areas, using different Workflows;

The rule is not triggered for Project Areas using the same Workflow.

Cause

The workflow used by the issue type does not have the "Fire a Issue Created event that can be processed by the listeners." event at the Post-functions for the new transition.

Solution

  • Edit the workflow;

  • Click at the new transition to show the menu options;

  • Select Post-Function;

  • Add a new event and select "Fire an Event" and the "Issue Created" option.

Updated on April 8, 2025

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