Problems with creating issues in the mobile app

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

This article only applies to Atlassian's server products. Learn more about the differences between cloud and server.

Problem

Can’t create issues in the mobile app.

Cause

Back in Jira 8.4, we’ve recommended disabling the createmeta REST endpoint that was used by Atlassian applications integrated with Jira to create issues, and replaced it with other endpoints. The mobile app is one of such applications, so it can’t create issues if the endpoint is disabled. For more info about this problem, see Createmeta REST endpoint to be removed.

Solution

We’ve added new endpoints that can be used by the mobile app to create issues. To use them, you’ll need to complete these steps:

  1. Upgrade the Jira mobile plugin to version 1.20, or the latest available on Atlassian Marketplace. This version is bundled with Jira 8.7, so you don’t have to do this if you’re using this version.

  2. Allowlist the following header on your Jira server:

    1 new-create-metadata-api: <boolean>

Updated on April 15, 2025

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