Problems Adding Comments to Tickets in Jira Data Center

Platform Notice: Data Center Only - This article only applies to Atlassian apps on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When adding a new comment, you get a pop-up error with the text: "Comment body can not be empty!", however, there are data/text within the comment body.

Environment

9.0.0

Diagnosis

This issue is observed after upgrading Jira to version 9.0.x.

Cause

It has been noticed that this issue is observed because of a third-party plugin "JIRA Threaded Comments v1.27.6 by AtlaZon". This plugin is not compatible with Jira 9.0.x. You can check if you have this plugin in your environment by following the below steps:

  • Please navigate to Manage Apps as

    (Auto-migrated image: description temporarily unavailable)

    Settings>Manage apps>Manage Apps

  • You can filter for third-party apps and look for "Jira Threaded Comments".

Solution

If you encounter this issue and if you have "JIRA Threaded Comments", it is recommended to disable the third-party plugin "JIRA Threaded Comments" and then test the behaviour again. To disable the application, you can follow below steps.

  • Please navigate to Manage Apps as

    (Auto-migrated image: description temporarily unavailable)

    Settings>Manage apps>Manage Apps

  • You can filter for the third party apps and look for "Jira Threaded Comments".

  • Expand "Jira Threaded Comments" like below and click on disable.

Updated on April 21, 2026

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