Priorities under dropdown are not updating in issue view

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

In the issue view of Jira service management projects, under context details priority field is set. An issue's priority defines its importance in relation to other issues, so it helps your users determine which issues should be tackled first. Jira comes with a set of default priorities: Highest, High, Medium, Low, Lowest.

You can modify these default priorities, create new ones, and add them to different projects.

Environment

Jira Service Management Cloud

Cause

Sometimes this priority does not update for existing and new issues on the issue view. For example, the values set is Very High in the configuration

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But it shows as Critical in the issues.

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This is caused due toTranslate prioritiesbeing different from the priorities set. Hence the values are not updated on issues.

Solution

To resolve this, please go to the translate priorities link and align the name and description as per the priorities defined in the section

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Still, the issue persists, the potential cause could be the backend cache not getting updated. Please raise a support ticket with Atlassian to investigate this further.

Updated on April 8, 2025

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