Poor performance in Jira Server or Data Center caused by Atlassian Developer Mode -Datlassian.dev.mode=true

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Atlassian Product can be set into Developer Mode as it is mentioned here: Enabling Developer Mode. This is what it looks like in the setenv.sh (for Linux) or setenv.bat (for Windows):

1 -Datlassian.dev.mode=true

Diagnosis

This option might be enabled for debugging purposes or trying out an extension or add-ons for JIRA. However, this will force JIRA to re-download the whole page being accessed, instead of caching the data. This could cause a performance issue when the amount of users accessing JIRA at the same time is high, as more load will be given to JIRA to handle.

Resolution

Look into Setting Properties and Options on Startup page on how to add parameter on the setenv.* file, but this time set the parameter to false:

1 -Datlassian.dev.mode=false

Or it is also possible to delete the parameter altogether, as this is not required for JIRA day to day basis usage.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.