Plugins not initializing due to loss of database connection.

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Upon Jira start up plugins fail to start.

The logs will show the Jira Database Startup checks completed successfully.

1 2022-05-20 18:37:18,219-0700 JIRA-Bootstrap INFO [c.a.jira.startup.DatabaseChecklistLauncher] Jira database startup checks completed successfully.

However, the logs will show plugins on the failed plugin report.

1 2 3 4 ******************************************************************************************************************************************************************************************************** ___ FAILED PLUGIN REPORT _____________________ 3 plugins failed to load during Jira startup.

Environment

Any Jira Server/Data Center instance.

Diagnosis

Within the atlassian_jira.log file during the start up process the following exceptions can be seen when starting plugins:

1 com.microsoft.sqlserver.jdbc.SQLServerException: The connection is closed.
1 Caused by: com.microsoft.sqlserver.jdbc.SQLServerException: Connection reset by peer: socket write error
1 2 java.lang.RuntimeException: Unable to obtain a connection from the underlying connection pool Caused by: com.microsoft.sqlserver.jdbc.SQLServerException: The TCP/IP connection to the host <database server>, port <port #> has failed. Error: "connect timed out. Verify the connection properties. Make sure that an instance of SQL Server is running on the host and accepting TCP/IP connections at the port. Make sure that TCP connections to the port are not blocked by a firewall.".
1 Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'applicationMetadataService': Bean instantiation via constructor failed; nested exception is org.springframework.beans.BeanInstantiationException: Failed to instantiate [com.adaptavist.tm4j.core.analytics.service.ApplicationMetadataService]: Constructor threw exception; nested exception is com.atlassian.cache.CacheException: com.atlassian.jira.exception.DataAccessException: com.microsoft.sqlserver.jdbc.SQLServerException: Cannot open database "<Database Name>" requested by the login. The login failed. ClientConnectionId:e44c340c-3895-4c1b-8b79-063bed6bcb11

đź’ˇIn the exceptions above the plugin names/classes could be different.

Cause

This can occur if the database is not available when attempting to load the plugins. Some plugins will reach out to the database to initialize data and validate licenses, if the database cannot be reached the loading of these plugins will fail.

Solution

Ensure full database connectivity during start up to allow plugins to start.

If the database connectivity issues are resolved, the plugins can be started manually.

Updated on April 2, 2025

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