Plugin Manager Doesn't Start Due to 'Duplicate plugin found'
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
After recently installing a plugin either by placing the jar file in <JIRA-HOME>/plugins/installed-plugins/
directory or via the Administration > Plugins page, JIRA's Plugin Manager fails to start up with the following message:
1
Error occurred while starting Plugin Manager. Duplicate plugin found (installed version is the same or older) and could not be unloaded: 'com.atlassian.upm.atlassian-universal-plugin-manager-plugin'
Cause
There are two different versions of a plugin installed onto the JIRA server.
Resolution
Remove all versions of the plugin and re-install the latest compatible version.
A plugin may have been installed in the following locations depending on whether or not it is a Version 2 or Version 1 plugin:
First, shutdown JIRA
Version 2:
Plugin files are located within:
<JIRA-HOME>/plugins/installed-plugins/
Remove any *.jar files associated with the problematic plugin
Version 1:
Plugin files are generally located within: <JIRA-INSTALL>/atlassian-jira/WEB-INF/lib
ℹ️Note that the plugin may have special instructions beyond the norm. In this case, please refer to the plugin's installation documentation for further info.
Remove any *.jar files associated with the problematic plugin
Restart JIRA once files have been removed
Re-install the plugin via JIRA's Add-on Manager
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