Picking a user for the Reporter or Assignee field fails with error after Jira server upgrade
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
After JIRA upgrade, picking a user from the Reporter or Assignee field throws the following error message when connecting to an LDAP server:
"The JIRA server was contacted but has returned an error response. We are unsure of the result of this operation"
Cause
Some of the JIRA users did not have an email address associated with it. Typing the first letter on the user picker throws the error, typing the second letter makes the user selection worked correctly.
Diagnosis
Diagnostic Steps
Verify whether all of the users in JIRA have an email address associated with it. If there are some users with no email address, add in their email address details:
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SELECT * FROM cwd_user WHERE email_address IS null or email_address = '';
Resolution
Update the affected users in the database with valid emails:
Stop JIRA
Run the following SQL query:
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UPDATE cwd_user SET email_address = '<email-address>' WHERE user_name = '<user-from-previous-query>';
Start JIRA
If the above doesn't change the behavior:
Delete and recreate the LDAP directory
Perform a full sync with the new directory
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