Performing Action Results in 'Column ID Cannot be Null'
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
When performing any action in JIRA, an error is returned. Messages like the following appear in the logs:
1
org.ofbiz.core.entity.GenericEntityException: while inserting: [GenericEntity:ChangeGroup][id,null][author,jcurry][created,2010-02-22 12:00:00.000][issue,10001] (SQL Exception while executing the following:INSERT INTO changegroup (ID, issueid, AUTHOR, CREATED) VALUES (?, ?, ?, ?) (Column 'ID' cannot be null))
Cause
Database Communitcation:
The connection between JIRA and the MySQL database has been closed.
JIRA running into datatype errors
1
2
2013-09-04 14:54:01,589 http-8080-21 WARN anonymous 894x76552x1 - 172.22.50.64 /rpc/soap/jirasoapservice-v2 [ofbiz.core.entity.SequenceUtil] '2.14748369E9' in column '1' is outside valid range for the datatype INTEGER.
2013-09-04 14:54:01,589 http-8080-21 ERROR anonymous 894x76552x1 - 172.22.50.64 /rpc/soap/jirasoapservice-v2 [ofbiz.core.entity.SequenceUtil] [SequenceUtil.SequenceBank.getNextSeqId] Fill bank failed, returning null
Basically JIRA assigns the unique IDs that are stored in the database. In the above error, the ID count had reached an extremely high number, resulting into datatype errors.
Resolution
If the cause is due to database communication issues:
In order to prevent this problem from happening in future, add a validation query which JIRA will use when communicating with its database. For more details on how to set the validation query, see:
Surviving Connection Closures (in the documentation for JIRA 4.4.x and later) or
Surviving Connection Closures (in the documentation for JIRA 4.3.x and earlier).
If the cause is due to JIRA running into datatype errors:
The ID counter will need to be reset, but this may be difficult depending on the table. Please create a ticket with Atlassian Support
Atlassian Support Refer to case here...
https://support.atlassian.com/browse/JSP-171355
Please ensure that the database changes would not cause major data loss
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