Password Reset E-mail Not Sending the Correct Message in Portuguese
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
This problem is related to a third party plugin, and therefore not supported by Atlassian. See Atlassian Supported Plugins for more information.
Symptoms
When reseting the password using the Brazilian Portuguese language pack, users receive an email with the following message:
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Você (ou outra pessoa) solicitou uma nova senha.
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Sua senha foi alterada para: {0}
Cause
The problem is with the language_pt_BR.jar file.
In the older JIRA versions, the password was sent in the body of the email when the 'reset password' option was used. In JIRA 4.1.2, only the reset password link is sent in the message. The language_pt_BR.jar was not updated to reflect the change.
Resolution
Change the following line in the
<JIRA_install>/atlassian-jira/WEB-INF/lib/language_pt_BR/com/atlassian/jira/web/action/JiraWebActionSupport_pt_BR.properties
enclosed in this jar file:1
template.user.forgotpassword.passwordchanged = Sua senha foi alterada para: {0}
to
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template.user.forgotpassword.passwordchanged = Clicando no link abaixo, sua senha pode ser alterada.
Re-zip or re-jar the file.
Restart JIRA.
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