Password change with existing mail server setup is not taking effect

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Change Password option in Outgoing SMTP mail server doesn't update the authentication credential password:

(Auto-migrated image: description temporarily unavailable)

Environment

Jira 8.10.1 and above

Diagnosis

Editing the existing SMTP mail server in Jira does not update the mailpassword value in mailserver database table.

Bug ticket for outgoing mail server – JRASERVER-71867 - Change password doesn't update the mail server setup with the new password for Outgoing Mail

Bug ticket for incoming mail server – JRASERVER-71771 - Updating incoming mail server password does not work

Workaround

  • Delete and re-create the mail server with the new password.

    OR

  • Update the base64-encoded-password into the database table, e.g:

    1 UPDATE mailserver SET mailpassword='<base64-encoded password>' WHERE name = '<mail server name in Jira>';
Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.