OutOfMemory due to Custom Services

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

JIRA crashes or behaves unpredictably. Logs contain errors like:

1 java.lang.OutOfMemoryError: Java heap space

Cause

Occasionally people write their own services, which can cause memory problems if (as is often the case) they iterate over large numbers of issues.

The CVS service is an example of one service that can cause memory problems, if used with a huge CVS repository (in this case, simply increase the allocated memory).

A symptom of a CVS (or general services-related) problem is that JIRA will run out of memory just minutes after startup.

Resolution

  1. As a temporary measure, increase JIRA's Heap Space allocation.

  2. From Admin >> Services, check for any services other than the usual.

  3. If you have any custom services, please try disabling it as a test, to eliminate as a cause of problems.

Updated on April 24, 2025

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