Opsgenie Sign-Out throws an error at logout and redirects to previous SSO(IDP provider page)

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

An error is thrown when users logout from the Opsgenie app after signing out they are redirected to the old IDP/SSO provider.

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Environment

Cloud

Diagnosis

The SLO configuration was picking up the old Service Provider config file and it required to be cleared out so the system could pick up the updated configuration. 

Cause

Old SP configuration was being picked up and hence the app was redirecting to the old SSO provider page.

Solution

Within  https://instanceurl.app.opsgenie.com/settings/sso go to the relevant IDP provider and take a backup of the current IDP provider configuration.

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Ensure that you clear out all the values from the previous IDP provider and then update back the current IDP provider configuration under SSO settings.

Updated on March 19, 2025

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