Opsgenie/Jira Android Mobile app login issue on Huawei mobile devices
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
You are not able to log in to Opsgenie/Jira Android Mobile application on Huawei mobile devices.
Environment
Jira/Opsgenie Cloud Android Mobile Application.
Diagnosis
When you try login into the Opsgenie/Jira Android Mobile application via a Huawei mobile device you are redirected to the login page (id.atlassian.com). Once you enter the credentials, the application displays a blank page and you are not redirected back to the application after successful authentication.
Cause
When you try to log in via the application you are redirected to Huawei's in-app Browser to enter your login credentials, which is not a supported browser by Atlassian. Due to this, the redirection back to the application after successful authentication does not work as expected.
Please take a look at the following document to know more about Supported Browsers from Atlassian: Supported browsers for Atlassian cloud products
Solution
The solution for such a case would be to change your Default Web Browser on the Mobile Device. Here is an Article that can help you change the Default Browser on a Huawei Mobile device:
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