One specific user is not getting Slack notifications triggered by Jira automation

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

Why one of the users is not getting Slack messages when an issue is transitioned from one status to another via automation

Environment

Jira Cloud

Diagnose

Custom field name: Testers

Custom field ID: 10039

The 'testers' custom field, is of type User Picker (multiple users) which is used as a plain value.

If more users are added to this specific field, it will be converted to a string with a comma as a separator.

That means `@` will be added to the first user in the list. (the user email address gets `@` appended to it, which makes the email address invalid.)

Cause

It was found that '@' symbol was used in the message screen for Send Slack message.

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Solution

  • We modified the automation rule and made changes in the message screen for Send Slack message by removing the '@' symbol from the given syntax for Tester.

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  • Upon executing the rule, it worked as expected and the slack notifications were received successfully.

Updated on April 8, 2025

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