Old name of a renamed custom field still being used in Field Configuration

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Custom field defined called 'XXX' which has been in use previously. Renamed the field to 'YYY' and re-indexing was done.

However the Field Configuration that uses this field still sees it as 'XXX' and issues that previously had values for this field show the bame 'XXX'. However for new issues or issues that didn't previously supply a value for this field, they use the new name for the field 'YYY'.

Cause

Possibly JIRA is still storing the old cache of the custom field and that causes the old names to appear.

Resolution

  1. Shutdown JIRA instance

  2. Delete the contents of the JIRA Home Directory\plugins\.osgi-plugins directory

  3. Delete the contents of the JIRA Home Directory\plugins\.bundled-plugins directory

  4. Delete the contents of the JIRA Installation Directory\work directory

  5. Delete the contents of the JIRA Home Directory\caches\indexes directory

  6. Restart JIRA instance

  7. Perform re-indexing

Updated on April 8, 2025

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