Notifications are not being sent to customers mentioned in internal comments in Jira Service Management Data Center

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Email notifications are not being sent to customers mentioned in internal comments in Jira Service Management projects.

Environment

Jira Service Management 4.20.0+.

Cause

For customers there is no concept of "mention" notification - this is a type of notification reserved for agents (users with a license). Instead, when customers (reporters, participants, approvers, members of organization the request is shared with) are mentioned in a public comment, they can receive the "Public comment" type of customer notification. If the comment is internal, then no notification will be sent to the users treated as customers. This is the expected behavior.

Solution

This behavior is as expected. To ensure that customers receive a notification, they must be mentioned in public comments.

Updated on April 8, 2025

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