Notification from JIRA contains unknown attachment

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Problem

When user receive notification from JIRA, the notification contains attachment like ATT00001.htm, ATT00002.htm and so on)

Diagnosis

  • Looking into the notification that contains the unknown attachment, only notification with known attachment contains the additional unknown attachment.

Cause

The unknown attachment is added because the attachment body part in an e-mail message is sent before the message body part of the e-mail message is sent. This is mentioned in the Microsoft KB below:

Solution

Workaround

  1. Reorder the order of the body sent by following instruction from Microsoft KB : https://support.microsoft.com/en-us/help/969854/the-body-of-a-message-is-shown-incorrectly-as-an-attachment-if-you-try-to-use-an-application-in-an-exchange-server-environment-to-send-a-message-that-includes-attachments

  2. If the solution from KB is not application (eg: if the mail server is Office 365 based), user can try different Mail Server which is POSTFIX based.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.