Not Found (404) when performing the Bulk Edit Group or editing smtp settings
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
When trying to bulk edit groups or edit smtp settings, you will hit into the following Not Found (404) error:

The following appears in the atlassian-jira.log
:
2013-07-30 13:32:53,917 http-danial-8080-exec-37 ERROR [500ErrorPage.jsp] Exception caught in 500 page org.apache.jsp.secure.admin.user.views.bulkeditusergroups_jsp
java.lang.ClassNotFoundException: org.apache.jsp.secure.admin.user.views.bulkeditusergroups_jsp
at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
at java.security.AccessController.doPrivileged(Native Method)
...
Cause
The java.lang.ClassNotFoundException indicates that there might be some missing classes in JIRA.
Resolution
Perform the following steps below to rebuild the missing classes again:
Shutdown JIRA instance
Delete the contents of JIRA Installation Directory\work directory
Restart JIRA instance
Was this helpful?