Not able to view Issue types from within the Project Settings
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
You are not able to view any Issue types from within the Project Settings, instead, you see the following error message in the UI:
An error occurred while loading the page.
Screenshot for the exact scenario:

At the time of the error, you should be able to see the following error stack trace in the atlassian-jira.log file:
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2022-10-18 15:41:33,269+0530 http-nio-48211-exec-24 ERROR user@domain.com 941x6139x3 lz1lx9 0:0:0:0:0:0:0:1 /rest/projectconfig/latest/issuetype/SDP/10101/fields [c.a.p.r.c.error.jersey.ThrowableExceptionMapper] Uncaught exception thrown by REST service: For input string: ""
java.lang.NumberFormatException: For input string: ""
at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)
at java.lang.Long.parseLong(Long.java:601)
at java.lang.Long.<init>(Long.java:965)
at com.atlassian.jira.workflow.WorkflowActionsBean.getFieldScreenIdForView(WorkflowActionsBean.java:68)
at com.atlassian.jira.issue.fields.screen.DefaultProjectFieldScreenHelper.findWorkflowsUsingScreen(DefaultProjectFieldScreenHelper.java:94)
at com.atlassian.jira.issue.fields.screen.DefaultProjectFieldScreenHelper.getAllProjectsForFieldScreen(DefaultProjectFieldScreenHelper.java:76)
... 3 filtered
at java.lang.reflect.Method.invoke(Method.java:498)
at com.atlassian.plugin.util.ContextClassLoaderSettingInvocationHandler.invoke(ContextClassLoaderSettingInvocationHandler.java:26)
at com.sun.proxy.$Proxy457.getAllProjectsForFieldScreen(Unknown Source)
... 3 filtered
at java.lang.reflect.Method.invoke(Method.java:498)
This is failing at WorkflowActionsBean.getFieldScreenIdForView, which means that Jira is trying to find a screen for a workflow transition, but instead is getting an empty string, see this specific error message:
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java.lang.NumberFormatException: For input string: ""
Diagnosis
In order to identify the workflow with a missing screen in the workflow transition you need to do either of the following:
Run the below SQL query which will find all workflows where the view is set to a value, but the corresponding fieldscreen id has no value:
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select * from jiraworkflows where descriptor ~ '(view=){1}((?!action).)*(<meta name="jira.fieldscreen.id"></meta>){1}';
From the above SQL output, you can copy the descriptor column output in the text editor and search for jira.fieldscreen.id with the missing screen ID for the workflow transitions explained below.
Export the workflow in XML format and save it locally. Then you can run the below grep command in the terminal from the location where you have downloaded the workflow.
Replace the
filename.xml
with the actual workflow filename:1
grep -n -B4 '<meta name="jira.fieldscreen.id"><' filename.xml | grep "view="
These are example workflows for valid and invalid configurations which causes this issue:
❌ The following example is invalid and needs to be fixed. Because of this, we are running into this issue
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<action id="41" name="Pending" view="fieldscreen">
<meta name="sd.resolution.clear"></meta>
<meta name="jira.description"></meta>
<meta name="jira.i18n.description"></meta>
<meta name="jira.fieldscreen.id"></meta>
ℹ️ From the above, if you see action id="41" has view="fieldscreen"
but the id of the screen is not defined below in <meta name="
jira.fieldscreen.id
"></meta>
✔️ The following example is valid and does not need to be fixed, this is because in the action tag no attribute with view="fieldscreen"
is mentioned when the transition Close happens.
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<action id="91" name="Close">
<meta name="jira.description"></meta>
<meta name="jira.i18n.description"></meta>
<meta name="jira.fieldscreen.id"></meta>
✔️ Another example that is valid and does not need to be fixed:
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<action id="121" name="Back to work in progress" view="fieldscreen">
<meta name="sd.resolution.clear"></meta>
<meta name="jira.description"></meta>
<meta name="jira.i18n.description"></meta>
<meta name="jira.fieldscreen.id">12912</meta>
Where do I find the id of the screen?
From the DataBase, if you know the screen name you can get the id from fieldscreen table:
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select * from fieldscreen where name like '%name%';
From the UI where the screen is associated with the transition:
If you open the workflow in text mode you should see actions associated with multiple transitions.
You will see that there should be a number associated with the transition that is <action id > number which you find in the XML format of the workflow (as shown above).
The below screenshot show's this.

If you click on Transition you should see if the screen is present or not.
The 2 screenshots below show one with the screen name and one without.


Cause
⚠️ In the XML format of workflow for any transition, if the screen id is missing in spite of mentioning the fieldscreen in the view attribute of the <action> tag, then you would encounter this issue.
💡We suspect this is most likely to occur if you are importing any workflow from one server instance into another in Jira during the import of workflow automatically assigns new screens and fields present in the existing server.
ℹ️ Because of the null screen ID in the workflow configuration, it prevents editing of the workflow from the UI.
Solution
You have three different options to resolve this problem:
Update the workflow with the id of the screen from UI :
Edit those workflows in the GUI using Text mode
Edit the respective transitions in Text mode, and make sure to use the correct ID see the example examples mentioned previously.
Add screens accordingly
Save & Publish the workflows
You can edit the XML workflow by exporting, modifying, and then importing it back in:
Export the Issue workflow locally in the XML format.
Edit the XML format of the workflow by updating the screen id.
Import the updated workflow and associate this with the respective Issue type.
You can update the affected workflows manually from within the DB (use this as a last resort in favor of the above options!):
Schedule downtime to Shut down Jira and take a full backup of the database.
Use the SQL query in step 1 of the Diagnosis to get the affected workflow.
You have to update the
descriptor
column only for impacted transitions.Work with your internal DBA for assistance in constructing the following query:
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update jiraworkflows set DESCRIPTOR = REPLACE(DESCRIPTOR,'<meta name="jira.fieldscreen.id"></meta>','<meta name="jira.fieldscreen.id">fieldscreen_ID</meta>') where ID in (workflow_ID);
⚠️ Take note of the following ⚠️
The 2 placeholders above must be replaced with the correct IDs for your instance:
fieldscreen_ID
workflow_ID
It is important to note that the query should not replace any transitions which do not have any screens.
Always back up your data before performing any modifications to the database. Please refer to this document for Backing up data. If you are making changes in the production environment. Please make sure you test the changes in the test environment before doing changes in the Production
Restart Jira and verify that the problem is gone.
Lastly, edit the affected workflows -> edit the transitions -> update them with the desired screens where necessary -> Save & Publish.
ℹ️ If you cannot edit a transition in Text mode (getting a similar error), retry editing it in Diagram mode by:
Edit the transition -> associate it with a screen -> save
If the transition shouldn't have a screen, then edit it again -> remove the screen -> save
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