Not able to create ticket in service project through Email due to issue field error in email logs

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

Encountered below error in email logs while sending email to JSM mail handler and ticket is not created.

1 Your request could not be created. Please check the fields have been correctly filled in. We can't create this issue for you right now, it could be due to unsupported content you've entered into one or more of the issue fields. If this situation persis...

Cause

There is a custom field which is not possible to update during issue creation via email.

Note

Note: The custom field details could be found by an Atlassian support engineer via Application logs. However, you could review the workflow to pinpoint the problematic field.

Solution

  1. Navigate to the associated workflow in Edit mode

  2. Select the "Create issue" transition

  3. Click on Post function link under this transition

  4. Locate if there are any post function which is setting/changing data for a custom field during issue creation

  5. Remove this post function and "Publish draft"

Updated on April 8, 2025

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