No Jira notifications are sent on custom workflow transitions

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When a custom workflow is being used, no email notifications are generated by Jira when custom workflow transitions are executed. Jira outgoing messages log does not contain any entries for attempts to send those email notifications out.

Diagnosis

Email notifications are triggered by the events subsystem, which is configured in the post functions for each individual workflow transition, usually at the last step. Events in JIRA can be of several types, which govern what kind of email template will be sent out if any.

Cause

Custom workflows by default have a Generic Event configured in workflow transitions (via their Post Functions configuration). If the Generic Event event is not configured in the Notification Scheme configuration to send out notifications, then no user will receive a notification when the transition is executed.

Solution

2 possible resolutions

  • Update the NotificationScheme configuration in the project to send out notification from the event Generic Event

  • Or change the event fired by the workflow post-functions to an event which is already configured to send notifications as per the NotificationScheme configuration in the project (for example, the Issue Updated event)

Updated on April 15, 2025

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