No Group Combo Box Shown in 'Edit User Group' Page Due to a Null Value on the Database

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptom

There isn't combo-box for 'Groups'/'Available Groups' displayed in 'Edit User Group' page and 'Bulk Edit Group Members' page. The following appears in the atlassian-jira.log:

1 2 3 4 5 Caused by: java.lang.RuntimeException: Null group name at com.atlassian.jira.user.util.GroupNameComparator.compare(GroupNameComparator.java:33) at com.atlassian.jira.user.util.GroupNameComparator.compare(GroupNameComparator.java:11) ...

Cause

One or more group(s) misses name in database, which may be caused by the wrong data manipulation of a 3rd party plugin or direct database insertion.

Resolution

  1. Back up JIRA

  2. Shutdown JIRA

  3. Run the below sql in the JIRA database:

    1 2 update groupbase set groupname='DATA-FIX' where groupname is null
  4. Reboot JIRA instance

  5. Reindex JIRA, from Administration >> System >> Indexing

  6. Go to Administration >> Group Browser, find 'DATA-FIX' group, delete or rename it.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.